RC-Monster Forums

RC-Monster Forums (https://www.rc-monster.com/forum/index.php)
-   Product Reviews (https://www.rc-monster.com/forum/forumdisplay.php?f=19)
-   -   Baja 1/5 Scale E Conversion Kit (https://www.rc-monster.com/forum/showthread.php?t=32295)

jcflyer 04.24.2016 10:52 PM

Baja 1/5 Scale E Conversion Kit
 
Anyone have any trouble with their kit? I got one last week went to build it and the screw holes are drilled wrong!!! Gonna call Mike tomorrow!!

Arct1k 04.25.2016 12:35 AM

Post up pics. You might have something the wrong way around

jcflyer 04.25.2016 07:14 AM

I don't have anything the wrong way, it only fits one way. The screw holes for the diff are just off a bit plain and simple...

Arct1k 04.25.2016 08:55 AM

There is a lot of flex in the chassis until everything is bolted tight. I remember having to keep most screws fairly loose until everything in place.

If it's not that ping Mike

jcflyer 04.25.2016 09:13 PM

Ok I tried everything and took measurements the front two holes are 1/2mm off. There is no getting around it, if you try to enlarge the big square hole then the two rear screws won't line up. Another plate is what's needed with the holes in the proper place!!

nitrostarter 04.25.2016 10:13 PM

Pictures??

jcflyer 04.25.2016 10:15 PM

Trying to post them now!!! They doing repairs to the site now can access!!!

jcflyer 04.25.2016 10:51 PM

Pics of the bottom plate!!!

http://i1379.photobucket.com/albums/...psxp8ukkpn.jpg

http://i1379.photobucket.com/albums/...psa1kmtvr7.jpg

RC-Monster Mike 04.26.2016 09:37 AM

That is definitely not the stock rear diff case - I propose that the issue is likely in the other part, as I am certain my cnc machine didn't simply decide to place the holes incorrectly this one time after making the same part for years. Maybe there is something else in the way? I see the mis-alignment in the picture, but I am certain the plate is the same as every other lower plate I've made since making this kit the 1st time several years ago.

jcflyer 04.26.2016 10:05 PM

Ok got the problem sorted out with help from Monster Mike!!! Thanks brother, turns out it is the Turtle Racing transmission case causing all the problems.
The holes are all out of whack!!!

nitrostarter 04.26.2016 10:53 PM

Thumbs up!


All times are GMT -4. The time now is 02:44 AM.

Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.