RC-Monster Forums  
RC Monster

Go Back   RC-Monster Forums > Support Forums > Castle Creations

Reply
 
Thread Tools Rate Thread Display Modes
Old
  (#121)
Colby
Guest
 
Posts: n/a
08.14.2008, 11:35 PM

Yep, I was going to call Castle first thing in the morning.
   
Reply With Quote
Old
  (#122)
DickyT
Guest
 
Posts: n/a
08.15.2008, 12:08 AM

2.5 hours on the v2 so far, 111 is the warmest it has seen yet. I need to gear up or volt up a bit and push the whole system a bit.
   
Reply With Quote
Old
  (#123)
ffactory666
Guest
 
Posts: n/a
08.15.2008, 12:22 AM

I don't know , yours is working great why try to push it .
   
Reply With Quote
Old
  (#124)
DickyT
Guest
 
Posts: n/a
08.15.2008, 12:50 AM

Quote:
Originally Posted by ffactory666 View Post
I don't know , yours is working great why try to push it .
because I would not be me if I did not. if it dies while being used within spec I'll send it back, no big deal. hopefully it stays strong.
   
Reply With Quote
Old
  (#125)
ffactory666
Guest
 
Posts: n/a
08.15.2008, 05:00 AM

Your a braver man than me
   
Reply With Quote
Old
  (#126)
ogrfre01
RC-Monster Carbon Fiber
 
Offline
Posts: 119
Join Date: Dec 2007
08.15.2008, 05:11 AM

I just recieved mine, it seems to work fine but i havnt tried it at the track, i only calibrate it and set it up with a castle link..... I just ran it on the garage floor... its reaaaally smooth..... smother then the MM (IMO). I´ll test it on the track efter work today if it has dried up......
   
Reply With Quote
Old
  (#127)
bl-is-future
RC-Monster Aluminum
 
bl-is-future's Avatar
 
Offline
Posts: 974
Join Date: Feb 2008
Location: Midland, MI
08.15.2008, 09:46 AM

yep i have pushed mine as hard as i can with my current electronics. (FP 5000mah 5s, 1515 1y, Extremely heavy alloy savage, MMM V1) if it dies i will send it in. If not i will still send it in next month when orders are taken care of.


I fly, I drive, but most of all I crash.
   
Reply With Quote
Old
  (#128)
mtfly2000
RC-Monster Stock
 
mtfly2000's Avatar
 
Offline
Posts: 30
Join Date: Aug 2008
Location: "The Coast", Washington
08.15.2008, 11:38 AM

Quote:
Originally Posted by DickyT View Post
I am not well needless to say weather was non compliant today, or more yesterday. It was dry today, but several days of rain prior had all the bash spots flooded. CC does not advertise waterproofness on the MMM, neither does nue and my rx is in a box but not sealed. I thought it best to just leave it in the car and drive home. I played for about 10 minutes in the parking lot of my house while talking to a neighbor. not hard enough to get anything warmer than ambient though. all super slow smooth driving, oh my is this esc smooth.

is waterproffness even a word?
Patrick has said that it's water resistant
   
Reply With Quote
Old
  (#129)
Edumakated
Guest
 
Posts: n/a
08.15.2008, 12:27 PM

I took mine out the the track last night and ran the snot out of it. Put 3 5s 5000 packs through it with the 1515 2.5d motor geared 23/46 in my rc8 which is good for about 45 mph.

The fan broke within the first 2 minutes on the track. Same problem as before with the plug breaking off the bottom of the board. I even put extra foam padding in the bottom of the case. Ran all night with no fan and it only got up to about 160 degrees.

When I got home, I cut the grill out of the top of the ESC and put in a Novak 30mm fan powered off the receiver. Works perfectly now.
   
Reply With Quote
Old
  (#130)
DickyT
Guest
 
Posts: n/a
08.15.2008, 12:31 PM

Quote:
Originally Posted by mtfly2000 View Post
Patrick has said that it's water resistant
yeah, but the fan lead is not. neither is my rx or motor. I have far too much money dumped into the revo money pit to even think about intentionally driving iit through water.

Quote:
Originally Posted by ffactory666 View Post
Your a braver man than me
or dumber.... lol

Quote:
Originally Posted by Edumakated View Post
I took mine out the the track last night and ran the snot out of it. Put 3 5s 5000 packs through it with the 1515 2.5d motor geared 23/46 in my rc8 which is good for about 45 mph.

The fan broke within the first 2 minutes on the track. Same problem as before with the plug breaking off the bottom of the board. I even put extra foam padding in the bottom of the case. Ran all night with no fan and it only got up to about 160 degrees.

When I got home, I cut the grill out of the top of the ESC and put in a Novak 30mm fan powered off the receiver. Works perfectly now.
It would be nice if the fan lead was not on the bottom side where it took impact, I want to play arond with mine, but I also want to keep it's warranty intact, I have 2 MM's that had warranty voided as soon as I took them out of the box as is...

Last edited by DickyT; 08.15.2008 at 12:35 PM.
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



RC Monster




Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com