RC-Monster Forums  
RC Monster

Go Back   RC-Monster Forums > Support Forums > Castle Creations

Reply
 
Thread Tools Rate Thread Display Modes
Old
  (#16)
Dagger Thrasher
I have no idea what's going on
 
Dagger Thrasher's Avatar
 
Offline
Posts: 464
Join Date: Jan 2005
Location: UK
08.09.2008, 06:04 PM

Oh man...this is turning into a total disaster. Sounds to me like some sort of internal short, or perhaps, for some reason, the TVS blew? That seriously sucks though; sorry to hear about it. Lets just hope this is an isolated case.
   
Reply With Quote
Old
  (#17)
gramey
RC-Monster Carbon Fiber
 
gramey's Avatar
 
Offline
Posts: 50
Join Date: Jul 2008
08.09.2008, 06:11 PM

Quote:
Originally Posted by coolrunnings View Post
MGM here I come!
Don't say that the CC lynch mob will be after you!


Losi 8T RR - Novarossi Plus 21-5BT/ Jammin JP3 - Teknorc 8T - Neu 1515-1Y - MGM 16025-3 Z Series ESC.
   
Reply With Quote
Old
  (#18)
phatmonk
RC carbon junkie
 
phatmonk's Avatar
 
Offline
Posts: 634
Join Date: Dec 2007
Location: Iowa
08.09.2008, 07:03 PM

Quote:
Originally Posted by lind5 View Post
this is not the news i wanted to hear i thought the problems had been ironed out
now thats two things i heard i wonder if it was to do with the fan wires
keep us posted
has anyone else got there v2 back a tried it yet

and o yeah sorry to hear about your mmm i bet your gutted
I got 1 of mine back today.It is in my 8T with a Tekno Neu 1515/1.5d/f and Maxamps 4s2p 6000 I ran for about 10 minutes and no problems to report.The temps here are in the 80s and the fan only came on once.I realy hope these failures are isolated incidents.Thanks CastleSorry guys that sucks yours failed I know you have been waiting.I think I will keep my mod MM for good luck.I hope and wish I dont need it.
   
Reply With Quote
Old
  (#19)
ffactory666
Guest
 
Posts: n/a
08.09.2008, 07:19 PM

Quote:
Originally Posted by jayjay283 View Post
ive ran my v2 for just over 3 hours combined time and no issues yet. Im trying to get Larry to say he screwed up so I feel better LOL but I know thats not the case. Ugh. Think I may take mine apart this evening and mod up the case and stuff like in BrianGs post.
What mods has BrianG done , tried looking for his post but couldn't find it .

After reading about a couple of issues with the fan wires on the v2, i'm thinking the fan wires might of cut through and shorted out on the board ?
   
Reply With Quote
Old
  (#20)
jayjay283
RC-Monster Titanium
 
jayjay283's Avatar
 
Offline
Posts: 1,777
Join Date: Feb 2008
Location: Illinois
08.09.2008, 07:42 PM

One of our gents had a nice how to and where to dremel fan plug fix somewhere..

http://www.rc-monster.com/forum/showthread.php?t=13512

http://www.rc-monster.com/forum/show...ght=MMM+dremel
   
Reply With Quote
Old
  (#21)
suicideneil
Old Skool
 
suicideneil's Avatar
 
Offline
Posts: 7,494
Join Date: Feb 2007
Location: Devon, England
08.09.2008, 07:45 PM

I believe he just cut the lid off, to allow for more natural air flow. A few others have dremelled the inside of the case, so that the plug for the fan doesnt rub on the inside of it (under the pcb, bottom half of the case). A few have ran the fan wires out of the top of the case and plugged it into the Rx, using a new fan though that isnt so prone to busting.

EDIT: beat me too it...
   
Reply With Quote
Old
  (#22)
Larrydino
RC-Monster Stock
 
Larrydino's Avatar
 
Offline
Posts: 38
Join Date: Jun 2008
Location: \
08.09.2008, 09:01 PM

Quote:
Originally Posted by Dagger Thrasher View Post
Oh man...this is turning into a total disaster. Sounds to me like some sort of internal short, or perhaps, for some reason, the TVS blew? That seriously sucks though; sorry to hear about it. Lets just hope this is an isolated case.
i hope its just an isolated case...i have another one on order!
   
Reply With Quote
Old
  (#23)
Sneaky Pete
RC-Monster Stock
 
Offline
Posts: 30
Join Date: Jun 2008
08.09.2008, 09:14 PM

Quote:
Originally Posted by jayjay283 View Post
One of our gents had a nice how to and where to dremel fan plug fix somewhere..
See this link...post #23

http://www.rc-monster.com/forum/show...ght=fan&page=2

Hopefully this mod won't be a moot point!

Last edited by Sneaky Pete; 08.09.2008 at 09:15 PM.
   
Reply With Quote
Old
  (#24)
phatmonk
RC carbon junkie
 
phatmonk's Avatar
 
Offline
Posts: 634
Join Date: Dec 2007
Location: Iowa
08.09.2008, 10:11 PM

If I never read these forums I wouldnt know about any of these failures due to this fan wire issue.Iam playen stupid and trusting CC on this one
   
Reply With Quote
Old
  (#25)
coolrunnings
Guest
 
Posts: n/a
08.09.2008, 10:37 PM

I'm sorry that was a typographical error I meant to say mgm sucks castle rules...lol.
   
Reply With Quote
Old
  (#26)
What's_nitro?
Soldermaster Extraordinaire
 
What's_nitro?'s Avatar
 
Offline
Posts: 4,529
Join Date: Apr 2007
Location: Plymouth, MA, USA
08.09.2008, 11:31 PM

Quote:
Originally Posted by FG101C View Post
Thats fantastic, now I don't know if I should even run it for fear of frying my battery. When my V1 went up in smoke I only got lucky that the battery did not go too.
There is NO WAY the controller will "fry" your battery. Especially if you run decent LiPo cells. Unless ALL of the FETs shorted at the same time (completely impossible). Whatever shorted would not be able to handle the current and would vaporize instantly with the 150-200+ amps put through it that a decent LiPo can produce. And you know what? If the battery did puff, it probably wasn't rated correctly! All of the failures I've read about thus far have been BEC/fan related which DEFINITELY would not hurt the battery AT ALL.
   
Reply With Quote
Old
  (#27)
ffactory666
Guest
 
Posts: n/a
08.10.2008, 02:13 AM

Thanks for the links to the MMM mod guys

However now i think about it more, what phatmonk said is very true and i am actualy getting peeeved now.
It's alright for us since we read these forums and can perform the mods .
What happens to the normal kid who buys one of these to run in his emaxx / revo and doesn't get on these forums as probably 99% of MMM customers.
How are they suppose to know how to perform these mods and that the mods are even needed .Not to mention that these mods void your warranty .

I couldn't wait to get my MMM , iv'e been waiting a couple of months now on backorder ( missed the first batch of backorders )
and have a new X2 truggy that i haven't run yet because of this delay.
It's sounding like some of you guys a crossing your fingers and hoping for the best when running the V2 .
Shouldn't you be able to use a product without the fear of it failing in the back of your mind.

I have used and still will use my MMs and i am buying a new Sidewinder for my 1/10 Pan Car , however i don't think CC should of released the MMM V2 if you still have to cut it up and mod it
Every issue on the v1 should of been rectified with the v2 which looks like at the moment this is not the case ( fan wires fraying and causing shorts , 2nd case of this happening is on RCtech forums ) and the need to run a seperate fan.

Think i might cancel my backorder and get another R1 Pro for the truggy .

Last edited by ffactory666; 08.10.2008 at 04:05 AM.
   
Reply With Quote
Old
  (#28)
TruckBasher
RC-Monster Aluminum
 
TruckBasher's Avatar
 
Offline
Posts: 554
Join Date: Jan 2007
Location: Singapore
08.10.2008, 04:32 AM

Its hard to comment on something you I dont have yet...I have 2 on backorder and now im thinking Luciano was right to hold off for another 6mos to make sure everything is good. I still hope this is an isolated incident and wont happen to other MMM V2.


E-Slayer direct drive to diff
Savage Flux 5T work in progress
   
Reply With Quote
Old
  (#29)
ffactory666
Guest
 
Posts: n/a
08.10.2008, 05:12 AM

Quote:
Originally Posted by TruckBasher View Post
Its hard to comment on something you I dont have yet...I have 2 on backorder and now im thinking Luciano was right to hold off for another 6mos to make sure everything is good. I still hope this is an isolated incident and wont happen to other MMM V2.
Another one dead during calibration , was just posted .It's not looking good .
   
Reply With Quote
Old
  (#30)
FG101C
RC-Monster Aluminum
 
Offline
Posts: 765
Join Date: Aug 2007
08.10.2008, 06:29 AM

Quote:
Originally Posted by What's_nitro? View Post
There is NO WAY the controller will "fry" your battery. Especially if you run decent LiPo cells. Unless ALL of the FETs shorted at the same time (completely impossible). Whatever shorted would not be able to handle the current and would vaporize instantly with the 150-200+ amps put through it that a decent LiPo can produce. And you know what? If the battery did puff, it probably wasn't rated correctly! All of the failures I've read about thus far have been BEC/fan related which DEFINITELY would not hurt the battery AT ALL.
Yes it is possible to lose the battery. When my V1 went up in smoke the wires from the battery lead to the esc board came unsoldered, had they shorted out in the chassis or together then the battery would have went up. The battery better have been rated correctly for a $260.00 Polyquest.

My question is this. Is this ESC for bashing only? I mean do you just put it in your truck, truggy and run it around in the street or in the grass? If so then the speed control works awesomely, but I plan on racing with it. Airing it out over large jumps, getting tangled in traffic, etc. If this is the case, and it's not built for racing then please CC let us know.

Thanks.
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



RC Monster




Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com