RC-Monster Forums  
RC Monster

Go Back   RC-Monster Forums > Support Forums > Castle Creations

Reply
 
Thread Tools Rate Thread Display Modes
Old
  (#16)
shaunjohnson
i pwn nitro
 
shaunjohnson's Avatar
 
Offline
Posts: 769
Join Date: Nov 2008
Location: with ur GF
05.18.2009, 05:05 PM

i hope you collected all the smoke so castle can put all the smoke back into it to repair it for you.


E-revo 3.3 conversion, 249kv outrunner, 6s, MMM
the porthole from the noob world an here has been opened!! that's how i got in.
  Send a message via MSN to shaunjohnson  
Reply With Quote
Old
  (#17)
Sylvester
RC-Monster Dual Brushless
 
Sylvester's Avatar
 
Offline
Posts: 3,493
Join Date: Feb 2005
Location: Canada
05.18.2009, 08:45 PM

Quote:
Originally Posted by DickyT View Post
and.... pictures of the carnage!



you can totally reuse those gold plugs


The problem with nitro's these days are that they arent brushless... LOL

Losi 8ight e
MMM / Neu 1512 2.5d/f
Thunderpower 5s 5000
  Send a message via MSN to Sylvester  
Reply With Quote
Old
  (#18)
mkrusedc
NeuMaxx
 
mkrusedc's Avatar
 
Offline
Posts: 1,286
Join Date: May 2007
Location: Near New Orleans
05.19.2009, 12:24 AM

Dang Dicky sorry to see you kill another. Glad the collateral was minimal. Every time I hear of one smoking I get a little more nervous about my V1......
   
Reply With Quote
Old
  (#19)
DickyT
Guest
 
Posts: n/a
05.19.2009, 07:58 AM

Mark, you are still running a V1? wow!
   
Reply With Quote
Old
  (#20)
TexasSP
Something, anything, nothing
 
TexasSP's Avatar
 
Offline
Posts: 2,747
Join Date: Mar 2006
Location: Houston, TX
05.19.2009, 09:58 AM

Seems to be that according to Patrick the issue was more firmware than the original units. Even of a V1 does die I believe CC will replace it at anytime and not just hold you to the 1 year deal.


www.cubicle101.com
A friends comic strip website.
   
Reply With Quote
Old
  (#21)
TheRandom1
RC-Monster Stock
 
Offline
Posts: 33
Join Date: Oct 2008
Location: Illinois
05.19.2009, 10:20 AM

Wow, and to think I've only killed one electric motor, nothing else. Only fire I've ever had was when my old "N" truck smacked a tree at full throttle and split the fuel tank. Fuel right next to the hot exhaust, didn't work so well. One quick fireball and it was done though, thankfully!
  Send a message via Yahoo to TheRandom1 Send a message via AIM to TheRandom1 Send a message via MSN to TheRandom1  
Reply With Quote
Old
  (#22)
MetalMan
RC-Monster Mod
 
MetalMan's Avatar
 
Offline
Posts: 5,297
Join Date: Mar 2005
Location: SoCal
05.19.2009, 12:39 PM

Quote:
Originally Posted by DickyT View Post
Mark, you are still running a V1? wow!
There are still some of us with them going strong


SH Z-Car, Custom Crawler, 8s Savage, 12s XTM XLB 1/7 buggy, 4wd 4-link rear/IFS Pro4 truck, Custom Hyper 10 Short Course, Belt-Drive Mammoth ST 1/8 truggy, 4s 17.5 MM Pro HPI Blitz
   
Reply With Quote
Old
  (#23)
badassrevo
Guest
 
Posts: n/a
05.19.2009, 01:58 PM

I run my V1 every weekend! works great and never gets hot.


Last edited by badassrevo; 05.19.2009 at 01:59 PM.
   
Reply With Quote
Old
  (#24)
DickyT
Guest
 
Posts: n/a
05.19.2009, 02:12 PM

Quote:
Originally Posted by badassrevo View Post
I run my V1 every weekend! works great and never gets hot.

My v3 never got hot either. until sunday. I temped it about 30 seconds before it fire balled and it was at 118 after running a half pack on a hot day.
   
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump



RC Monster




Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
vBulletin Skin developed by: vBStyles.com